Access denied on mysqldump connect

Dear Support & All,

I have been trying to implement a solution which involves dumping a database from our SingleStore cluster.
I have tried using mysql client on Windows and MariaDB client on Ubuntu.

mysqldump --host HOST --port 3306 --user USER -pPASSWORD --result-file singlestore_test.sql -B test
mysqldump: [Warning] Using a password on the command line interface can be insecure.
mysqldump: Got error: 1045: Access denied for user ‘ethings_test’@‘100.96.5.72’ (using password: YES) when trying to connect

Could You please advise what setting I have to check to let this command go through?
Thank You
Attila

Hi Attila! :fox_face:

So sorry to hear that you are experiencing this issue.
Are you still on managed service version is 7.6.16 ?

Have you tried running the following: Exporting a Single Database

You might have a typo since your password is linked to the -.

$ mysqldump -h 127.0.0.1 -u root -p password -P 3306 foo > foo.sql
1 Like

Dear Maria,
Thank You for the response. Our current software level of the cluster seems to be 7.6.21
I do not know if that is better or worse than 7.6.16 :slight_smile:

Hi arnaud!
Thank for the tip. Based on the documentation the password needs to be after the -p without a white space. I also tried it with white space and also with quotation marks, to no avail.

Here is a more complete documentation page about using dump. dump

Maybe with the username you use, you might not have the permission to use the dump command since you got access denied. Do you test it with an admin username?

1 Like