Audit_level is not changing from "OFF" to another status in SS Cluster


I want to enable “LOGINS ONLY” and restarted SS cluster.Command run sucessfully.
When I checked Audit logs files its not storing logs.


[memsql@rnd-2 singlestoredb-toolbox-1.14.4-e432b273e6]$ ./sdb-admin update-config --all --key "auditlog_level" --value "LOGINS-ONLY"
Toolbox is about to run 'memsqlctl update-config --key auditlog_level --value LOGINS-ONLY' on the following nodes:
    - On host ip:
      + 284B9D52BBECE93>
    - On host ip:
      + 96C198363DDDC963>

Would you like to continue? [y/N]: y
✓ Updated configuration on host ip
✓ Updated configuration on host ip
|                 MemsqlID                 |                   Message                   | Result  |
| 284B9D52BBECE935EF0CAA310> | Updated configuration on host ip | changed |
| 96C198363DDDC963A876A> | Updated configuration on host ip | changed |

Also Audit_level is not changing from “OFF” to “LOGINS_ONLY” State. Pls let us know how to enable audit logs in SS Cluster.

Logs after restarting cluster:

Variable_name  Value
auditlog_disk_sync     OFF
auditlog_level             OFF
auditlog_retention_period    0
auditlog_rotation_size            134217728
auditlog_rotation_time             3600
auditlogsdir                        /home/memsql/poc/memsql/Master/auditlogs


auditlogs dir:

[memsql@rnd-2 auditlogs]$ ll -h
total 4.0K
-rw-rw-r--. 1 memsql memsql 115 Feb  8 04:58 auditlog_rnd-2-3310_2023-02-08_04-58-36.log
[memsql@rnd-2 auditlogs]$ cat auditlog_rnd-2-3310_2023-02-08_04-58-36.log
0,2023-02-08 04:58:36.586,INFO: Log opened on MemSQL startup. Format version 2. Log level initiated at ALL-RESULTS
[memsql@rnd-2 auditlogs]$ pwd


I got the ans, its due to I am using the Free Edition of SingleStore license. Audit logging is only available for Premium edition licenses of SingleStore DB and hence, you will not be able to use it. Please refer to the below documentation for further details:

Configure Audit Logging · SingleStore Documentation 10

@divyank1 – thanks for sharing your solution!