Backup to Azure Blobs


When I make an backup of an old database, coming from a version 6.8 it throws the following error:

ERROR 1970 ER_SUBPROCESS_TIMEOUT_ERROR: Leaf Error (x.x.x.x.x:x): Remote connection timed out receiving data. No stderr returned.

However with new databases, created since version 7.1 there is no problem.

My current version is 7.5

Can you show the backup command you used? You can X out the keys or secrets if there are any.

And how big was the database? Was it columnstore or rowstore, mostly?

of course, the command is:
BACKUP DATABASE TO AZURE “containername/backupdatabasename” CREDENTIALS ‘{“account_name”: “acountname”, “account_key”: “acountkey”}’;

The database weighs 4GB and is mainly columstore.

Hi Jonathan,

Could you try seting subprocess_idle_timeout to 30 minutes? And how big are the other databases?

Increasing the value to 30 minutes throws this new error:
ERROR 2205 ER_SNAPSHOT_SUBPROCESS_EXITED_WITH_NONZERO_RESULT: Leaf Error ( Backup subprocess nonzero exit value. -> memsqld/vendor/, /data/freya-worker/memsql/go/src/memsqld/vendor/ HTTP request failed Put

Did this get resolved somehow?
I’m receiving the same error too.
on 7.5.8


In my case the database was migrated from a 6.8 to 7.+ version.

And only in this database the problem occurred.
What I chose to do is to recreate the database and perform the backup.

That solved my problem.