Enabling Advanced counters

how to enable advanced counters in managed database, for seeing device read/write time, etc. Documentation suggests running a command
Enable advanced counters

But on running the command, following error is seen. How to proceed?

SET GLOBAL read_advanced_counters = ON

ERROR 1227 ER_SPECIFIC_ACCESS_DENIED_ERROR: Access denied; you need (at least one of) the SUPER privilege(s) for this operation

Can you say more about why you want to do this on the managed service?

If it’s critical for you to have this now, you can open a support ticket and they may be able to change it for you.

Hi kshastry,
We don’t enable advanced counters by default as they can have a 10-20% performance impact when turn on, but we can certainly turn it on for you. If you message me the username you used to create your cluster I can get it configured for you.

We are in the process of adding this permission to default users in the managed service, so in the future you will be able to set this yourself.