How do I run on RHEL6/7 without root access, and no docker?

"I wasn’t able to test MemSQL as I wasn’t able to get it to run in our environment. I don’t really remember the details of how I tried to run it, but basically I have only RHEL6/7 without root access, and no docker etc. So my MemSQL tests essentially finished without even starting.

Is it possible to get MemSQL to run in the constrained environment like I have? Probably not a problem for a DBA team or some “official” project, but for some “grass-roots” experiments that may be not ideal."

  • posted for V

Hi Vasily

Thanks for asking the question (and Lucas for reposting!)

Just out of curiosity, did you follow this specific guide to install on RHEL?

https://docs.memsql.com/guides/latest/install-memsql/on-premises/single-host/native/step-2/

If so, what are some errors you see? The more information you can give us, the better – thanks!

1 Like

Hi Vasily, you should be able to follow our comprehensive install here: https://docs.memsql.com/guides/latest/install-memsql/on-premises/multi-host/comprehensive/step-1/

We are also updating the setup cluster tool to support non-root installations, which should provide a simplified installation process for just this type of situation. You can expect to see this enhancement land in our tools package in the next couple months.

1 Like

Hi @mbhakti,
looks like the guide still refers to sudo privileges. Is it possible to create a Docker image (using root) which can be run without root privileges? I can’t find any Dockerfile sources for the official images (which I would modify)

To deploy without sudo privileges our recommended process would be to follow our tarball installation guide: https://docs.memsql.com/v7.0/reference/memsql-tools-reference/deploy-memsql/deploy-memsql-via-tarball/

Would that work for you, or do you need to run memsql in containers?