Incorrect alert configuration example

The example at Configure Alerts is incorrect.

It yields:

root@singlestore0:~# cat /etc/singlestore-monitoring.yml
location:
email:
  receivers:
    - engineering@cyberfusion.nl
  sender: engineering@cyberfusion.nl
  server:
    host: smtp.prorelay.nl
    port: 587
    username:
    password:

root@singlestore0:~# sdb-report send-alert --config-file /etc/singlestore-monitoring.yml
invalid argument "/etc/singlestore-monitoring.yml" for "--config-file" flag: yaml: unmarshal errors:
  line 2: field email not found in type config.Config

It looks like email should be under location, like this:

root@singlestore0:~# cat /etc/singlestore-monitoring.yml
location:
  email:
    receivers:
      - engineering@cyberfusion.nl
    sender: engineering@cyberfusion.nl
    server:
      host: smtp.prorelay.nl
      port: 587
      username:
      password:

root@singlestore0:~# sdb-report send-alert --config-file /etc/singlestore-monitoring.yml

Thanks for pointing this out. I’ll take a look at it and make any necessary updates.

ETA: Yep, identified and fixed in the next round of documentation updates, coming today/tomorrow. Thanks again for pointing it out!

1 Like