"memsql-cluster-crd.yaml" recognition error on k8s latest version (v1.23.4)

Hi,

“memsql-cluster-crd.yaml” recognition error on k8s latest version (v1.23.4)

When deploying to the latest version of k8s (v1.23.4), the error for the file “memsql-cluster-crd.yaml” is shown:

[root@k8s-master memsql]# kubectl apply -f memsql-cluster-crd.yaml -n memsql
error: unable to recognize "memsql-cluster-crd.yaml": no matches for kind "CustomResourceDefinition" in version "apiextensions.k8s.io/v1beta1"

For reference, there is no problem in v1.20.15.

Can you provide me with the “memsql-cluster-crd.yaml” file of a version recognized by the latest version (v1.23.4)?

Or
update the documentation for deploying to the latest version of k8s (v1.23.4).

https://docs.singlestore.com/db/v7.6/en/deploy/kubernetes/create-the-object-definition-files/memsql-cluster-crd-yaml.html

Best regards…

Hello @kyoungho.kum,

We are in the process of updating the SingleStore Operator and documentation, I would expect soon (in a few weeks) for updates to be published to our public docs with a new CRD which will come with an updated release version of the Operator. This release version will support Kubernetes 1.22 and beyond.

In the meantime, if you need to test Operator functionality now, you will need to use Kubernetes 1.21.

Kind regards,
Cindy

3 Likes

@kyoungho.kum Did you try v1.21 succesfully?

1 Like

No, I didn’t tried that version.
I tried 1.20.15 (latest to 1.20), and it worked.
And, I used minikube.

$ minikube version
minikube version: v1.25.1
commit: 3e64b11ed75e56e4898ea85f96b2e4af0301f43d


$ minikube start -p aged --kubernetes-version=v1.20.15
* [aged] minikube v1.25.1 on Centos 7.9.200
...```
1 Like

@kyoungho.kum, @cynn I’m currently trying with 1.21 and I’m getting this error for memsql-cluster:

error: no kind "MemsqlCluster" is registered for version "memsql.com/v1alpha1" in scheme "k8s.io/kubectl/pkg/scheme/scheme.go:28"

I can use the create command with no problem, but no cluster pods appear, only the operator one. If I check using the logs command, I get the error above.

I’m sorry you are experiencing this issue Miguilim!

As this post has been flagged as resolved, would you be able to create a new post in the help section so community members can see it and offer support?
Thanks

@miguilim ,

Please make sure you have created the CRD. From the error, it looks like the CRD is missing.

You can find the CRD template in our docs:
https://docs.singlestore.com/db/v7.3/en/deploy/kubernetes/create-the-object-definition-files/memsql-cluster-crd-yaml.html

1 Like