Memsql License Update


We are using memsql-ops(yet have not moved to memsql tools) and in our development environment (which is small env with just 1host having both master and one leaf node) the license has been expired. Looks like int the MemSQL Customer Portal free license does’t support the memsql-ops (memsql-ops license-add --license-key). Is there a way to update the license that support memsql-ops.

First off, I highly recommend switching to tools. Recent versions of ops support generating a cluster file which you can use with memsql-deploy setup-cluster --cluster-file to “migrate”.

But, if you want to stay with Ops, you can use modern license keys as long as your ops version is 6.7.6 or higher. Just make sure to surround the license key in quotes on the terminal as some shells will escape various characters in the license key.

We are planning to move to the memsql tools with the next upgrade, but for now we wanted to keep the version same as our prod.

Even with the quotes it did not help, getting the same error as

MemSQL license is not valid: License key doesn’t exist

MemsqlOps : 6.7.5
Agent version : 6.7.5
memsql version: 6.7.18
Here is the example code(note the below key not my actual license key)
memsql-ops license-add --license-key "mZDEwYTBkMzY1AAAAAAAAAAAEAAAAAAAAAAwwNQIYJ/hpxFt9So1zMUt8iGcwvByNt1650kvmAhkA9Kuh+Yvmh6KkiVSJJ8JJlpfiftWFv/13AA=="

Will try upgrading the ops version and check, suspecting that would be the problem.

Upgraded the memsql-ops to 6.7.6 and tried updating, this time saw different error MemSQL license is not valid: The master aggregator must be online to validate this license. ConstraintError: NOT NULL constraint failed: memsql_licenses.capacity_mb. Note that my master aggregator is online.

Unfortunately Ops 6.7.6 seems to not support more recent versions of the license. As Ops is deprecated and being actively phased out, this isn’t something we would fix. The most recent version of Ops supports the new license keys, so if you want to stay with Ops for now you will need to upgrade. Sorry about that.

Thank you @carl tt worked after upgrading to the latest one

1 Like