Securing SingleStore DB: Authentication and Administration

I have completed the course ’ [Running Developer Labs in Docker]’ (Loading)
All went well and four containers are running.
I then started the course ‘Securing SingleStore DB: Authentication and Administration’
I issued the command from Windows Powershell: ssh -i ~/.ssh/singlestorekey.pem ubuntu@localhost and I was logged in correctly to ubuntu@localhost.

When I run the next command in the course: memsql -uroot I receive this message -bash: memsql: command not found

I am in the /home/ubuntu directory

What am I doing wrong or misunderstanding completely, please.

Or is the singlestore.pem file possibly the incorrect one for the container???

Many thanks.

Thanks for bringing this to our attention. We will get that fixed as soon as possible. Try this command instead. singlestore -u root -p

Let us know how that goes.

Thank you Lorrin.
I get the same result:
singlestore -u root -p
-bash: singlestore: command not found.
Many thanks.

We’ll investigate and get back to you.

Hey there!

It seems you may have skipped a course in between these two courses. Our apologies! I’ll make sure to make it clearer in the dashboard the order in which to complete the courses.

You’ll want to complete the courses in the following order:

  • Running Administrator Labs Using Docker (it seems you may have complete the Developer one?)
  • Online (Or Offline) Deployment of SingleStore DB
  • Securing SingleStore DB: Authentication and Administration

The second course above, the deployment course, will take you through the steps to install and deploy singlestore, including the client package singlestore-client, which allows you to connect directly to your cluster via the command line.

Also, quick note - “Memsql” was the name of our software before we changed it to “SingleStore” back in 2020. For example, the issue you ran into, -bash: memsql: command not found, would say -bash: singlestore: command not found if you were to run the command singlestore -uroot. You may see references to packages and commands that begin with “memsql” in our training content. We are actively working to update all of our videos and labs. Rest assured that both commands will still work the same.

Hi Donovan.
I did courses * Online (Or Offline) Deployment of SingleStore DB and have installed singlestore-client, singlestoredb-toolbox, singlestoredb-studio.

The command memsql is available but, as far as I can remember during the course ’ Docker Administrator Lab Setup’ no root password was created. Maybe it was and I have forgotten it.
If there is a default, please could you help with that.
If I set one, how do I fix the situation please. Can I change it?
I am getting the output:

ERROR 2003 (HY000): Can't connect to MySQL server on '' (111)

Sorry for the noob question.
Many thanks

Hey there, not a noob question at all!

What is the command you are running to generate that error?

Hi Donovan.
Thanks for your reply.
As I don’t have a password or can’t guess it, I try to log in with

memsql -u root -p
Enter password:

and get a response:

ERROR 2003 (HY000): Can't connect to MySQL server on '' (111)

I have tried passwords memsql, password or no password.


Gotcha! And did you deploy your SingleStore cluster using the Browser UI? If you created your cluster using the Browser UI recently, I believe we mandate a password for the root user during deployment.

Hi Donovan.
Thank you for replying to me.
I figured out where I was going wrong.
It was everywhere.
So I fixed up where I was going wrong and everything is working well.
Thank you for your patience.

Hey there,

That’s great to hear! Awesome problem solving :slight_smile:

We are currently working on making this Administrative course more streamlined as we speak. Learners will be able to breeze through it with much less road bumps. Thanks for reaching out!

I have learned a lot.

1 Like