Setup and Change high availability flag


i was trying same as per Change high availability flag this ticket But for its not working can u please let me know what is the issue here?

[root@vm_1 memsql]# memsql-deploy setup-cluster --high-availability=false --license BDky5NTY4ZmExMDA1MzcyZDVlAAAAAAAAAAAEAAAAAAAAAAwwNQIZAMqz/WFYKhaChhVO++p80eTdoFv4PeIls/eQrxpL+sAA== --master-host VM_1 --aggregator-hosts VM_1 --leaf-hosts VM_2 --password test
duplicate host “VM_1” found (consider using --cluster-file flag so as to register multiple nodes on the same host)

[root@vm_1 ~]# cat /etc/hosts|grep -i VM VM_1 VM_2

[root@vm_1 ~]# ping VM_1
PING VM_1 ( 56(84) bytes of data.
64 bytes from VM_1 ( icmp_seq=1 ttl=64 time=0.022 ms
64 bytes from VM_1 ( icmp_seq=2 ttl=64 time=0.040 ms

[root@vm_1 ~]# ping VM_2
PING VM_2 ( 56(84) bytes of data.
64 bytes from VM_2 ( icmp_seq=1 ttl=64 time=0.339 ms
64 bytes from VM_2 ( icmp_seq=2 ttl=64 time=0.166 ms

i tried with hostname & ip still the same what could be the issue here?

even i tried with --cluster-file but didnt helped.

Can you share which version of SingleStoreDB Tools you are using to deploy? I would recommend using the latest, which is 1.15.2 currently, and if you can share what type of hosts you’re installing on I can help to give more input.

If you are following this guide: CLI Online Deployment - Red Hat Distribution · SingleStore Documentation double check that you are running sdb-deploy setup-cluster with --allow-duplicate-host-fingerprints if you are using VM images which have duplicate SSH host keys.

If you are just looking to play around with SingleStoreDB we also offer a free trial in the cloud which may be an easier way to get started: SingleStoreDB Cloud - Try SingleStoreDB Cloud for Free

Let me know if this helps.