Unable to bootstrap master aggregator due to "invalid license"

I’m in the process of spinning up a MemSQL cluster inside AWS and have bumped into a problem where it’s reporting my license is invalid. I’m using the license from the portal.memsql.com site, which has worked without issue for me in the past. I’ve also tried setting the verbosity level up higher (with -v=3) to see if I can attain more information about why it’s invalid, but nothing useful came from that.

The steps I’ve taken to build up the cluster are:

  • Spin up three t3.xlarge CentOS 7 EC2 instances in AWS
  • Install memsql-toolbox
  • Run memsql-toolbox-config register-host ... to add all three hosts
  • Run memsql-deploy install ... to install memsql on all three hosts
  • Run memsql-admin create-node ... to create nodes on all three hosts

Then when I run memsql-admin bootstrap-aggregator --host <master_host> --license <license from portal> I get the error

stderr: a valid license is required to bootstrap a node to a master aggregator. Re-run 'memsqlctl bootstrap-aggregator' with the '--license' flag to automatically set the license before attempting to bootstrap the node

I’ve also tried setting the license more directly with memsql-ctl set-license, which succeeds, but then I still get the same invalid license error when I try to bootstrap a master aggregator afterwards.

memsqlctl show-license prints out the following

| MemSQL ID          | <my-memsql-id>|
| License            | <my-license>  |
| License_version    | 4             |
| License_capacity   | 4 units       |
| License_expiration | 0             |
| License_type       | free          |

I also note that this is different to the error I get if I just put some random text in place of the license key (stderr: Error 1888: Unable to reload license file: The provided license is invalid).

I’ve tried blowing the EC2 instances away and re-creating them and then starting over with no success as well.

Has anyone bumped into this before? If not, is anyone aware of how I could go about determining why the license is “invalid”?

Thanks for your interest in MemSQL, and really sorry that you’re having troubles.

Would you mind telling which version of the toolbox (memsql-admin version, but any other command should give you work) and which version of MemSQL are you using? I’m asking because we recently made updates to those error messages and newer versions should have had more informative error messages.

With older toolbox we have seen error message like yours when master memsqld couldn’t connect to memsqld on other hosts because of firewall settings. Particularly, are you able to establish a connection from your master host to any other non-master MemSQL instance? (Would telnet <otherhost> 3306 be able to connect?)

Finally, does you license happen to have any special characters (like + or /)? I don’t think we have had problems with this, but just wanted to rule this possibility out.

Thanks for the reply! I’m using that latest version of the memsql-toolbox, with memsql-admin at version 1.5.2.

I’ve resolved this now, the issue was in fact that I only had the SSH ports open between the hosts, and opening that up further got me past the issue. The error message was just a bit of a red herring.