Unable to create a new Cluster: invalid root credentials

on a virtual machine Centos 7 I have installed a single host cluster-in-a-box using a user with sudo permissions.
Later, I’ve tried to create a new cluster by MemSQL - Studio as described in https://docs.memsql.com/v7.1/guides/deploy-memsql/self-managed/linux/step-4/. The guide says I have to enter “root” as username and an empty password but I get an invalid credentials error

How can I solve this impediment?



I am wondering if you did set up a root password when you installed the MemSQL instances. Can you try this command successfully to get into MemSQL command line client:

your Linux prompt>memsql -P 3306 -u root -p

The system will prompt you for the password, hit enter.

Do you get some kind of password errors?


Thanks for the quick reply. Yeah, I had not realized I set up a password during the installation process. Is there a way to change it into an empty one?

sure, run this sql command:

set password for ‘root’@’’ = password(’’);

The command was uncorrect as the percentage sign was missing. No problem. I solved my issue.
Thanks a lot!

set password for ‘root’@’%’ = password(’’);